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CHAPTER 1 

Learning about new features in 
Ipswitch WhatsUp Gold v12 

In This Chapter 

Welcome to WhatsUp Gold ...............................................................................1 

What's new in WhatsUp Gold v12 ...................................................................1
 
 

Welcome to WhatsUp Gold 

Ipswitch WhatsUp® Gold delivers comprehensive and easy-to-use application and network 
management that provides 360° visibility, actionable intelligence and complete control of 
network and application infrastructures. With proactive monitoring of all critical network 
devices and services, WhatsUp Gold reduces costly and frustrating downtime.  

WhatsUp Gold identifies network problems and provides awareness and understanding of 
network performance and availability by:  

 discovering and mapping all your network devices  

 notifying you when problems occur on the network  

 gathering network information over time and generating reports  

 gathering real-time network information and providing second-by-second performance 
data 

 providing anytime, anywhere network monitoring 
 

What's new in WhatsUp Gold v12 

Ipswitch WhatsUp Gold v12 introduces a number of new features and enhancements that 
help you manage your network more efficiently than ever. One of the major features, Split 
Second Graphics (SSG), adds real-time graphs to provide instant feedback about network 
device performance. This SSG feature, coupled with the existing WhatsUp Gold performance 
reporting, provides a new level of network device performance intelligence to the already 
powerful historical performance data reporting capabilities in WhatsUp Gold.  
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New in WhatsUp Gold Standard, Premium, Distributed, and MSP 
Editions 
 High Capacity SNMP interfaces - added support for high capacity SNMP interface 

counters through the Interface Performance Monitor. 

 NetSNMP MIB - Unix performance monitoring with NetSNMP agents.  

 Custom names for SNMP interfaces - SNMP interfaces can be configured with unique 
identifiers. 

 Cisco MIB support - includes support for over 200 Cisco MIBs for monitoring Cisco 
equipment and services. 

 SNMP MIB Walker - new web-based network tool allows you to browse for SNMP objects 
that a device supports. 

 SNMP MIB Explorer - new web-based network tool allows you to browse for SNMP 
objects defined in MIB files. 

 SNMP MIB Manager - new web-based network tool for the import and validation of MIB 
files. 

 Improved SNMP API - supports enhanced scripting capabilities with both Script Action 
and Active Script Monitor. 

 Email Actions - now supports SMTP authentication. 

 SMS Direct - extended Short Message Service (SMS) support for SMS Direct. 

 Drag-and-Drop Management - enhanced drag-and-drop capability to include device, 
group, and map management on the web interface. 

 Upgraded Database Engine - MSDE 2000 database has been upgraded to Microsoft SQL 
Server 2005 Express. 

 Passive Monitors - have been enhanced to use device credentials stored in the 
Credentials Library. 

 Windows Vista support - Windows Vista Ultimate or Windows Vista Business (Windows 
Vista SP1 recommended) both as a WMI monitored OS and as monitoring workstation. 

 New licensing technology - requires users to enter a serial number to activate all of the 
WhatsUp Gold products. 

New in WhatsUp Gold Premium, Distributed, and MSP Editions 
 InstantInfo - provides instantaneous access to real-time performance data in enabled 

reports. 

 Split Second Graphs - provides real-time graphical data in performance workspace and 
full reports, the Web Task Manager, and the Web Performance Monitor. 

 Web Performance Monitor - new web-based network tool that provides insight into 
processes running on a device or system.  

 Web Task Manager - new web-based network tool that provides network device 
overview information about processes that use SNMP or WMI device connections. 

 Email Monitor - innovative monitor that uses SNMP, POP3, or IMAP by sending emails to 
servers, with support for encryption and SMTP authentication. 

 Dashboard Screen Manager - a stand-alone application designed to display a series of 
Web pages, or a "playlist," on one or multiple monitors. 
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Learning about the WhatsUp Gold new application features 
The matrix below highlights new features that are available in each edition of  
WhatsUp Gold v12: 

New WhatsUp Gold v12 Features Standard 
Edition 

Premium 
Edition 

MSP 
Edition 

Distributed 
Edition 

SSG (Real-time data)     

Support for instant access to real-time data via 
InstantInfo popups 

    

Web Performance Monitor network tool which 
creates Split Second Graphs for use in the 
Performance Monitor workspace report 

    

Web Task Manager troubleshooting network tool     

Support for Split Second Graphs that provide real-
time graphical data in performance workspace 
and full reports, the Web Task Manager, and the 
Web Performance Monitor 

    

SNMP     

Support for high capacity SNMP interface 
counters through the Interface Performance 
Monitor 

    

Support for NetSNMP agents for UNIX CPU 
utilization 

    

Support for configurable interface name for SNMP 
interfaces 

    

Includes select Cisco MIBs for use in WhatsUp 
Gold 

    

SNMP MIB Walker network tool which allows you 
to browse for SNMP objects on a device 

    

SNMP MIB File Explorer network tool which allows 
you to browse for SNMP objects in defined MIB 
files 

    

SNMP MIB Manager network tool which allows 
you to import and validate MIB files 

    

  3 



 WhatsUp Gold v12.0 New Features Guide 

Includes SNMP COM API improvements for 
enhanced scripting capabilities with the Script 
Action and Active Script Monitor 

    

Email     

Email Monitor with support for encryption and 
SMTP authentication 

    

Support for SMTP authentication for email actions     

SMS     

Extended Short Message Service (SMS) support for 
SMS Direct 

    

Drag-and-Drop     

Added support for drag-and-drop device, group, 
and map management on the web interface 

    

SQL Server 2005 Express Database     

Microsoft SQL Server 2005 Express Database     

Passive Monitors     

Added support for Passive Monitors to use device 
credentials in the Credentials Library 

    

Other Features     

Added the Dashboard application     

Added support for Windows Vista     

Added new licensing technology     
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System requirements 

Minimum software requirements 
 Windows XP Professional SP2 (or later), Windows 2003 Server SP1 (or later), Windows 

Vista Ultimate, or Windows Vista Business (Windows Vista SP1 recommended). 

 Microsoft Internet Explorer 6.0 SP1 (or later) or Firefox 2.0 (or later) 

 Microsoft .NET Framework v 2.0 or 2.0 SP1 

 Microsoft Windows Scripting Host v5.6 or later  

Windows Scripting Host is installed with the Windows operating system. To verify your 
version, run cscript.exe at a command prompt. 

If you need to update Windows Scripting Host, refer to the Microsoft Windows Scripting 
Host site (http://www.ipswitch.com/wsh56). 

 Internet connectivity for activation, connecting Central and Remote Sites, and running 
the web interface. 

Minimum hardware requirements 
 Intel Pentium-compatible 2 GHz or faster 

 1 GB memory (RAM) (2 GB RAM recommended) 

 256 MB of drive space (up to 4 GB additional for SQL Server 2005 Express Edition database 
and 7200 RPM drive recommended) 

 Display resolution support for 1024 x 768 minimum; recommended display resolution is 
1280 x 1024. 

 CD-ROM drive 

 Network Interface Card (NIC) 

 Modem and phone line (for pager, SMS, or beeper actions; modem pooling is not 
supported) 

 GSM modem and active SIM card (for SMS Direct actions) 

 SAPI v5.1 and supporting sound card for Text to Speech Actions; SAPI v5.1 can be 
downloaded from the Microsoft Speech site 
(http://www.microsoft.com/speech/speech2007/default.mspx). 

Microsoft SQL Server 2005 Express Edition (SSEE) requirements 
 SSEE supports up to 4 GB database size and up to 1 GB RAM for the buffer pool. Ensure 

sufficient disk capacity is available for data storage. 

 Note: SSEE supports one CPU. In computers with multiple CPUs, SSEE utilizes only one 
processor. 
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About Real-Time Data features 

 Note: These features are only available in WhatsUp Gold Premium Edition, WhatsUp Gold 
MSP Edition, and WhatsUp Gold Distributed Edition. 

 

The historical performance data that WhatsUp Gold tracks helps you discover and analyze 
network usage trends that have already occurred; however, at times you need to view device 
usage data immediately, in real time. 

WhatsUp Gold includes several features that enable you to monitor performance data in real 
time. 

 InstantInfo popups. Throughout workspaces and full reports, you can hover over some 
links (such as hard drive names or network interfaces) to see real-time data. 

 Web Task Manager and Web Performance Monitor. These Web-based network tools 
extend the functionality of familiar Windows tools to every device you monitor in real 
time--even for devices that do not run Windows. 

 Split Second Graphs Workspace Reports. These reports allow you to add real-time data 
into any workspace view. 

 Real-time data in Full Reports. Many full reports now include a graph that updates with 
up-to-the-minute information. This real-time data is paired with historical data to give you 
a comprehensive report. 
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Using InstantInfo popups 

InstantInfo popups provide easy access into real-time data that corresponds to the historical 
data viewed in performance workspace and full reports. The historical report data shows you 
device trends over the recent past hours, whereas InstantInfo popups provide dynamic 
graphs that show the latest device trends over the past minutes and seconds. 

To determine if real-time data is available for a report, hover over each link in the report (in 
most cases, the InstantInfo popups are triggered by the link on the second column in the 
report). If more information is available for the link, a continuously updating graph of real-
time data appears. 

 

 Important: InstantInfo popups require a minimum screen resolution of 1024 x 768 pixels, but 
is optimized for screen resolutions of 1280 x 1024 pixels and higher. 

 

Disabling InstantInfo popups 
By default, InstantInfo popups are available in both workspace and full reports, but you can 
disable them if you prefer. 

To disable InstantInfo popups: 
1 In the WhatsUp Gold web interface, click GO.  
2 From the WhatsUp section of the GO menu, click Configure > Preferences. The User 

Preferences dialog appears.  
3 Under InstantInfo (popups), clear the checkboxes for the areas where you do not want 

popups to appear. 
4 Click OK to save changes. 
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Using Network Tools to view real-time data 

WhatsUp Gold includes two network tools you can use to view real-time data on network 
devices, the Web Task Manager and Web Performance Manager. These network tools provide 
the capability to view real-time device data directly from the WhatsUp Gold web interface. 
 

Using the Web Performance Monitor 
The Web Performance Monitor extends the functionality of the Microsoft Windows 
Performance Monitor to the Web. It is a data collecting and graphing utility designed 
specifically for the WhatsUp Gold Web interface that graphs and displays real-time 
information on user-specified SNMP and WMI performance counters. It can be used for a 
quick inspection of a specific network device.  

 

The graphs can be saved to the database and displayed on workspace views using the Split 
Second Graph - Performance Monitor workspace report or on the Web Performance Monitor 
tool. Multiple SNMP and WMI counters can be displayed on a single graph, and the color and 
scale of each graphed item can be individually configured.  

Graphs created with the Web Performance Monitor are saved on a per-user account basis, 
meaning, graphs are only accessible by the user account that created and saved them. 

  9 



 WhatsUp Gold v12.0 New Features Guide 

The Web Performance Monitor has two purposes: 

 To provide a Web enabled WMI and SNMP performance counter poller and grapher. It 
supports WMI for Windows servers, and SNMP for network devices such as switches, 
routers, and UNIX devices. 

 To build and edit graphs for use by the Performance Monitor workspace report. You can 
use this workspace report to display any saved graph. 

To add a WMI performance counter to the Web Performance Monitor: 
1 Open the Web Performance Monitor. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Performance Monitor. The Web 
Performance Monitor appears. 

2 Click Graph > Add WMI Performance Monitor. 

- or - 

Click the WMI button in the top-right side of the dialog (see the Toolbar buttons table 
below). The Add WMI Performance Counter dialog appears. 

3 Enter the appropriate information into the dialog fields. 
4 Click OK to save changes. 

To add a SNMP performance counter to the Web Performance Monitor: 
1 Open the Web Performance Monitor. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Performance Monitor. The Web 
Performance Monitor appears. 

2 Select Graph > Add SNMP Performance Monitor.  

- or - 

Click the SNMP button in the top-right side of the dialog (see the Toolbar buttons table 
below).  

The Add SNMP Performance Counter dialog appears. 

3 Enter the appropriate information into the dialog fields. 
4 Click OK to save changes. 

Web Performance Monitor menu items 
The Web Performance Monitor menu is located at the top left corner of the window. 

File menu  

 File > New Graph. This menu item resets the graph back to a blank graph. 

 File > Edit Graph Name. This menu item lets you change the name of the selected graph. 

 File > Load Graph. This opens the Load Graph dialog, which displays a list of saved graph 
files on the Web server. 

 File > Save Graph. This saves the current graph to the database. If no filename is 
specified, it launches the Save Graph dialog, which allows a filename to be specified. All 
files are saved to the WhatsUp database. 
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 File > Save Graph As. This opens the Save Graph dialog which prompts you for a 
filename, and then saves the current graph to disk. 

 Windows Properties. This opens the Configure Window Properties dialog. Use this 
dialog to configure the graph and window properties for the Web Performance Monitor. 

Graph menu 

 Graph > Add WMI Performance Counter. This launches the Add WMI Performance 
Counter dialog.  

 Graph > Add SNMP Performance Counter. This launches the Add SNMP Performance 
Counter dialog. 

 Graph > Edit Selected Counter. This launches the appropriate dialog for editing the 
selected WMI or SNMP performance counter.  

 Graph > Remove Selected Counter. This removes the selected counter from the list and 
graph. No changes are saved to disk until the OK button is clicked or the graph is 
manually saved (File > Save Graph - or - Save Graph As). 

Help menu 

 Help > Help. This launches help for the Web Performance Monitor. 

Web Performance Monitor Toolbar buttons 
The Web Performance Monitor Toolbar is located at the top right corner of the window. 

Button Function 

 

Opens the Add WMI Performance Counter dialog. 

 

Opens the Add SNMP Performance Counter dialog. 

 

Opens the appropriate dialog for editing the selected WMI or SNMP performance 
counter.  

 

Removes the selected graph item from the list and graph. 

 

Opens the help topic for the Web Performance Monitor 

For troubleshooting information, see Troubleshooting SNMP and WMI connections in the 
Help. 
 

Using the Performance Monitor workspace report 
The Performance Monitor workspace report allows you to add a graph that you create in the 
Web Performance Monitor to a home workspace view. 

To use the Performance Monitor workspace report: 
1 In Web Performance Monitor, create and save the graph you want to use in the 

Performance Monitor workspace report. 

a) From the WhatsUp section of the GO menu, select Tools > Web Performance 
Monitor. The Web Performance Monitor appears. 
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b) From the Graph menu, add the WMI and SMP counters that you want to graph. 

c) After the graph is configured to show the data you want to see in the Performance 
Monitor workspace report, select File > Save Graph as. The Save Graph dialog 
appears. 

d) Enter a name for the graph, then click OK. Your graph is saved and ready to use in the 
Performance Monitor workspace report. 

2 Add the Performance Monitor workspace report to a home workspace view. 

a) From any home workspace view, click Add Content. The Add Content to View dialog 
appears. 

b) Expand the Split Second Graphs section, select Performance Monitor, then click 
OK. The dialog closes and the home workspace view appears with the new 
Performance Monitor workspace report added. 

c) On the new Performance Monitor workspace report, click Menu > Configure. The 
Configure Line Chart dialog appears. 

d) In Graph name list, select the graph you created. You can optionally configure any 
other options on this dialog to your preferences.  

e) Click OK. The dialog closes and the home workspace view appears with your custom 
Web Performance Monitor graph displayed in the Performance Monitor workspace 
report. 

 

Using the Web Task Manager 
The Web Task Manager extends the functionality of the Microsoft Windows Task Manager to 
provide network device overview information about processes occurring on a device, device 
performance, and device interface activity. The Web Task Manager graphs and displays real-
time information using SNMP or WMI device connections.  
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You can use the Web Task Manager to identify device issues and take corrective action on a 
device. 

 

There are three tabs that provide device information: 

 Processes. Provides key indicator process information for a selected device that WhatsUp 
Gold is monitoring. For example, you can view a list of .exe files that are running and the 
amount of CPU and memory used by each program. 

 Performance. Provides dynamic performance information for a selected device that 
WhatsUp Gold is monitoring. For example, you can view details about the CPU and 
memory usage.  

 Interfaces. Provides information about a selected device's interfaces that WhatsUp Gold 
is monitoring. For example, you can view a list of interfaces that the device uses learn 
about how much data is transmitted and received via each interface.  

 Note: When viewing information for devices running Microsoft Windows, information 
gathered via WMI is displayed in real time. Information gathered by SNMP, however, may 
reflect a delay of one minute or more. This delay is caused by a limitation in how often 
Microsoft Windows updates SNMP values. 

To use the Web Task Manager: 
1 Open the Web Task Manager. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Task Manager. The Web Task Manager 
appears. 
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2 Enter or select the appropriate information for the following fields: 

 Address or hostname. Enter a device IP address to select a device for which you want 
to view process information. Click Reconnect to connect with a device that has 
disconnected from the Web Task Manager. 

 Browse (...). Click to open the Web Task Manager Credentials dialog and set a WMI 
user name and password or an SNMP read community. The credential options are 
provided from the credentials stored in the Credentials Library. 

 Speed. Select the speed at which you want to monitor the device performance. 

 Normal. Updates device information every one second. 

 Medium. Updates device information every five seconds. 

 Slow. Updates device information every ten seconds. 

 Paused. Stops updating device information. 

 Connect using. Select the device protocol (WMI or SNMP) used to monitor and 
manage the device. The credentials stored in the Credentials Library are used to 
connect and read information on the selected device. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered by SNMP may reflect a delay of one minute or more. This delay is caused by a 
limitation in how often Microsoft Windows updates SNMP values. For this reason, we 
recommend using a Speed of Medium or Slow when using SNMP to view interface 
information about a device running Microsoft Windows. 

3 At the bottom of the Task Manager page, select the tab that you want to use 
(Processes, Performance, or Interfaces). 

4 For troubleshooting information, see Troubleshooting SNMP and WMI connections in 
the Help. 

 

Using the Web Task Manager - Process tab 
The Processes tab provides key indicator process information for a selected device that 
WhatsUp Gold is monitoring. This information helps you learn about device processes and 
identify trends and issues that occur on a particular network device. You can use the Web 
Task Manager to view the processes running on WMI- or SNMP-enabled network devices. 

 Note: Microsoft Windows Server 2003 reports the VM Size column information in Kilobytes 
instead of Bytes. This is a known issue to be corrected in a future WhatsUp Gold release. 
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After you have identified a process that is causing device performance issues, such as an 
application executable like Outlook.exe running multiple instances of the program, you 
can correct the problem to bring the device performance back to normal. 

 Note: Unlike the Windows Task Manager, you cannot terminate processes using the Web 
Task Manager. To terminate a task, you must log in to the computer where the task is running 
and use the Windows Task Manager to end the process. 

To use the Web Task Manager: 
1 Open the Web Task Manager. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Task Manager. The Web Task Manager 
appears. 

2 Enter or select the appropriate information for the following fields: 

 Address or hostname. Enter a device IP address to select a device for which you want 
to view process information. Click Reconnect to connect with a device that has 
disconnected from the Web Task Manager. 

 Browse (...). Click to open the Web Task Manager Credentials dialog and set a WMI 
user name and password or an SNMP read community. The credential options are 
provided from the credentials stored in the Credentials Library. 

 Speed. Select the speed at which you want to monitor the device performance. 

 Normal. Updates device information every one second. 
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 Medium. Updates device information every five seconds. 

 Slow. Updates device information every ten seconds. 

 Paused. Stops updating device information. 

 Connect using. Select the device protocol (WMI or SNMP) used to monitor and 
manage the device. The credentials stored in the Credentials Library are used to 
connect and read information on the selected device. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered by SNMP may reflect a delay of one minute or more. This delay is caused by a 
limitation in how often Microsoft Windows updates SNMP values. For this reason, we 
recommend using a Speed of Medium or Slow when using SNMP to view interface 
information about a device running Microsoft Windows. 

3 At the bottom of the Task Manager page, select the tab that you want to use 
(Processes, Performance, or Interfaces). 

4 For troubleshooting information, see Troubleshooting SNMP and WMI connections. 

 Note: Some differences exist in column names between the Web Task Manager and 
Windows Task Manager in Windows Vista and Windows 2008. The Mem Usage column in 
Web Task Manager is named Working Set (Memory) in Windows Task Manager on 
Windows Vista and Windows 2008. The VM Size column in Web Task Manager has no 
corresponding column in Windows Task Manager on Windows Vista and Windows 2008. 
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Using the Web Task Manager - Performance tab 
The Performance tab provides dynamic performance information for a selected device that 
WhatsUp Gold is monitoring. This information helps you learn about device performance and 
identify trends, spikes, or other issues that occur on a particular network device. You can use 
the Web Task Manager to view device performance for devices that are WMI or SNMP 
enabled network devices. 

 

After you have identified a performance issue that is causing device performance issues, such 
as the Page File Usage indicating that the system memory is nearly at full capacity, you can 
correct the problem to bring the device performance back to normal. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered via WMI is displayed in real time. Information gathered by SNMP, however, may 
reflect a delay of one minute or more. This delay is caused by a limitation in how often 
Microsoft Windows updates SNMP values. 
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To use the Web Task Manager: 
1 Open the Web Task Manager. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Task Manager. The Web Task Manager 
appears. 

2 Enter or select the appropriate information for the following fields: 

 Address or hostname. Enter a device IP address to select a device for which you want 
to view process information. Click Reconnect to connect with a device that has 
disconnected from the Web Task Manager. 

 Browse (...). Click to open the Web Task Manager Credentials dialog and set a WMI 
user name and password or an SNMP read community. The credential options are 
provided from the credentials stored in the Credentials Library. 

 Speed. Select the speed at which you want to monitor the device performance. 

 Normal. Updates device information every one second. 

 Medium. Updates device information every five seconds. 

 Slow. Updates device information every ten seconds. 

 Paused. Stops updating device information. 

 Connect using. Select the device protocol (WMI or SNMP) used to monitor and 
manage the device. The credentials stored in the Credentials Library are used to 
connect and read information on the selected device. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered by SNMP may reflect a delay of one minute or more. This delay is caused by a 
limitation in how often Microsoft Windows updates SNMP values. For this reason, we 
recommend using a Speed of Medium or Slow when using SNMP to view interface 
information about a device running Microsoft Windows. 

3 At the bottom of the Task Manager page, select the tab that you want to use 
(Processes, Performance, or Interfaces). 

4 For troubleshooting information, see Troubleshooting SNMP and WMI connections in 
Help. 

The following are examples of information that is provided when you connect to and view a 
WMI enabled device. Note, this information varies by operating system: 

 CPU Usage. This graph indicates the percentage of time the processor is operating. Use 
this graph to view how much the processor is operating. 

 CPU Usage History. This graph indicates how much the processor has operated over 
time. You can change the Speed option (High, Normal, Slow, Paused). The Speed option 
determines how often updates occur to the CPU Usage History. 

 PF Usage. This graph indicates how much page file memory is used.   

 Page File Usage History. This graph indicates how much the page file memory is used 
over time. If page file memory usage is high, you may want to increase the available page 
file memory. 
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 Totals. This provides the total number of Handles, Threads, and Processes occurring on 
the selected device. 

 Commit Charge (K). Provides information about the memory (Total, Limit, and Peak) 
allocated to the operating system and applications running on the device. 

 Physical Memory (K). Provides information about the amount of physical memory (Total, 
Available, and System Cache) installed on the device.  

 Kernel Memory (K). Provides information about how much memory (Total, Paged, and 
Nonpaged) the operating system kernel and device drivers are using. 

 Note: Values reported for Peak and System Cache will differ from values reported by the 
Windows Task Manager on the actual device. In the Web Task Manager, Peak reflects the 
peak value for the time that the Web Task Manager has been open only, and System Cache 
does not include the size of the free page list. 

The following information are examples of the information that is provided when you 
connect to and view a SNMP enabled device. Note, this information varies by operating 
system: 

 In (PKTS). Provides detailed information about the network packets that this device 
receives. 

 Out (PKTS). Provides detailed information about the network packets that this device 
sends. 

 System. Provides general system information about CPU performance, the number of 
interfaces that are running on the device, the total amount of time the device has been 
operating in the up mode, and the version number of Cisco software running on the 
device (if applicable). 

For troubleshooting information, see Troubleshooting SNMP and WMI connections in the 
Help. 
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Using the Web Task Manager - Interfaces tab 
The Interfaces tab provides information about the interfaces available on a selected device 
that WhatsUp Gold is monitoring. This information helps you determine how much data is 
transmitted and received via each interface, and therefore may help you locate an interface 
that using an unexpected amount of bandwidth. 

 

After you have identified the interface that is causing bandwidth performance issues, such as 
a file sharing application exposing shared files on a computer for others on the Internet to 
access and download, you can correct the problem to bring the device performance back to 
normal. 

The Web Task Manager includes the following columns: 

 Description. This column is the text description of the interface as configured on the 
device. 

 Index. This column is the unique numerical indentifier of the interface as defined on the 
device. 

 Transmit %. This column indicates what percentage of the interface's capacity is 
currently being used to transmit data. 
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 Receive %. This column indicates what percentage of the interface's capacity is currently 
being used to receive data. 

 In Bandwidth (kbps). This column shows the amount of data received by the device in 
kilobits per second. 

 Out Bandwidth (kbps). This column shows the amount of data transmitted by the device 
in kilobits per second. 

To use the Web Task Manager: 
1 Open the Web Task Manager. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Tools > Web Task Manager. The Web Task Manager 
appears. 

2 Enter or select the appropriate information for the following fields: 

 Address or hostname. Enter a device IP address to select a device for which you want 
to view process information. Click Reconnect to connect with a device that has 
disconnected from the Web Task Manager. 

 Browse (...). Click to open the Web Task Manager Credentials dialog and set a WMI 
user name and password or an SNMP read community. The credential options are 
provided from the credentials stored in the Credentials Library. 

 Speed. Select the speed at which you want to monitor the device performance. 

 Normal. Updates device information every one second. 

 Medium. Updates device information every five seconds. 

 Slow. Updates device information every ten seconds. 

 Paused. Stops updating device information. 

 Connect using. Select the device protocol (WMI or SNMP) used to monitor and 
manage the device. The credentials stored in the Credentials Library are used to 
connect and read information on the selected device. 

 Note: When viewing information for devices running Microsoft Windows, information 
gathered by SNMP may reflect a delay of one minute or more. This delay is caused by a 
limitation in how often Microsoft Windows updates SNMP values. For this reason, we 
recommend using a Speed of Medium or Slow when using SNMP to view interface 
information about a device running Microsoft Windows. 

3 At the bottom of the Task Manager page, select the tab that you want to use 
(Processes, Performance, or Interfaces). 

4 For troubleshooting information, see Troubleshooting SNMP and WMI connections in 
the Help. 
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About Split Second Graphs 

Split Second Graphs are real-time graphs that display information on SNMP and WMI 
performance counters. These real-time graphs can be viewed on the Web Performance 
Monitor network tool see Using the Web Performance Monitor (on page 9), and the WhatsUp 
Gold Device and Group Performance Full Reports (see Learning about full reports) for:  

 CPU 

 Disk 

 Interface 

 Memory 

 Ping 

 Custom monitors*  

*Split Second Graphs are currently not used with scripted monitors. 

 Note: Although you must turn on a specific Performance Monitor (CPU, Disk, Interface, 
Memory, Ping) in order to view data on it, you do not have to turn on a Performance Monitor 
to view its Split Second Graph information. (This is not the case for Custom Performance 
Monitors. You must configure and turn on a Custom Performance Monitor for its Split Second 
Graph to display data. For more information, see Configuring and enabling Performance 
Monitors in the Help). 
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While both Device and Group Reports display Spilt Second Graphs, they differ in the way the 
graphs are displayed. In Device Reports, the Split Second Graph appears at the bottom of the 
report page, under the main report graph.  
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In Group Reports, because multiple devices are displayed, you must choose a specific device. 
Do this by hovering over a device's Description (in the Description column of a Group 
Report). Doing so will bring-up a popup that displays this device's Split Second Graph for the 
Group Report you are viewing. 
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Split Second Graphs in Workspace Reports 
Along with the full reports, Split Second Graphs can also be found in several workspace 
reports. You will find these workspace reports in the workspace report picker under the Split 
Second Graphs category. In addition to these workspace reports, you can find Split Second 
Graphs in the Threshold category workspace reports. 
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The Split Second Graph - Performance Monitor workspace report allows you to display graphs 
that you configure with the Web Performance Monitor and save to your database. 

 

Each Split Second Graph displayed within workspace reports can be configured to display in 
different graph types, using different trend types, and in several dimensions. 
 

Using Split Second Graph Workspace Reports 
With Split Second Graph Workspace Reports, you can embed the real-time data that is 
available from InstantInfo popups, the Web Task Manager, and the Web Performance Monitor 
into any workspace view. 

For information on how to add a Workspace Report to a workspace view, see Adding 
workspace reports to a workspace view in the Help. 
 

Configuring a Split Second Graph workspace view 
Using Split Second Graphs, you can configure a workspace view dedicated to real-time data 
for your network devices.  

Consider the following questions in preparation for configuring a Split Second Graph 
workspace view: 

1 What type of real-time data would I like readily available? 
2 On what network devices would I like to view this real-time data? 
3 Is there information beyond WhatsUp Gold's pre-configured Split Second Graph 

workspace reports that I'd like in my workspace view? 
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Split Second Graph workspace reports 
After you determine what type of real-time data you would like in your workspace view, 
consider the types of Split Second Graph workspace reports available. 

There are multiple types of split second graph workspace reports that each displays a 
different type of real-time data. All of the available split second graph workspace reports are 
listed in the table below. 

Split Second Graph 
workspace reports 

Workspace 
report 
type Description 

Performance Monitor Home This workspace report displays custom real-time graphs for an 
SNMP or WMI enabled device. Multiple SNMP and WMI 
counters can be specified for a single graph. First, build the 
graph using the Web Performance Monitor tool and then save 
it to the database. The graph can then be shown in a Home 
Workspace view using the Split Second Graph - Performance 
Monitor workspace report. The chart attributes, such as size 
and display mode, are defined using the workspace report 
configuration dialog.  

Interface Home This workspace report displays real-time interface utilization 
for an SNMP enabled device. The device must have SNMP 
credentials specified in Device Properties > Credentials. 

CPU Home or 
Device 

This workspace report displays real-time CPU utilization for all 
CPU's on a SNMP enabled device. The device must have SNMP 
credentials specified in Device Properties > Credentials. This 
report queries the specified device for a list of all CPU's and 
then polls and graphs each of them for the duration that the 
report is loaded in the Web browser. 

CPU Gauge Home or 
Device 

This workspace report displays real-time CPU utilization for all 
CPU's on a SNMP enabled device. The device must have SNMP 
credentials specified in Device Properties > Credentials. This 
report queries the specified device for a list of all CPU's and 
then polls and graphs each of them for the duration that the 
report is loaded in the Web browser. 

Ping Home or 
Device 

This workspace report displays real-time PING response time 
for all network interfaces on a device. This report queries the 
database for a list of all configured network interfaces and then 
polls and graphs each of them for the duration that the report 
is loaded in the Web browser. 

Ping Gauge Home or 
Device 

This workspace report displays real-time PING response time 
for all network interfaces on a device. This report queries the 
database for a list of all configured network interfaces and then 
polls and graphs each of them for the duration that the report 
is loaded in the Web browser. 
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Split Second Graph 
workspace reports 

Workspace 
report 
type Description 

Disk Home or 
Device 

This workspace report displays real-time disk utilization for all 
disks on a SNMP enabled device. The device must have SNMP 
credentials specified in Device Properties > Credentials. This 
report queries the specified device for a list of all disks and 
then polls and graphs each of them for the duration that the 
report is loaded in the Web browser. 

Memory Home or 
Device 

This workspace report displays real-time memory utilization for 
a SNMP enabled device. The device must have SNMP 
credentials specified in Device Properties > Credentials. This 
report queries the specified device to determine if it can report 
memory utilization and then polls and graphs it for the 
duration that the report is loaded in the Web browser. 

Task Manager CPU Line 
Graph 

Home or 
Device 

This workspace report displays the CPU usage of specific 
device as a line graph. The device must have Windows 
credentials specified in Device Properties > Credentials. This 
workspace report shows current real-time data as well as 
historical data plotted on the line graph. The graph shows up 
to x seconds of historical data. 

Task Manager Memory 
Usage Line Graph 

Home or 
Device 

This workspace report displays the memory usage of specific 
device as a line graph. The device must have Windows 
credentials specified in Device Properties > Credentials. This 
workspace report shows current real-time data as well as 
historical data plotted on the line graph. The graph shows up 
to x seconds of historical data. 

Task Manager CPU Bar 
Graph 

Home or 
Device 

This workspace report displays a bar graph of the CPU usage of 
a specific device in real time. The device must have Windows 
credentials specified in Device Properties > Credentials. You 
must configure this workspace report and select a device 
before any data is reported. 

Task Manager Memory 
Usage Bar Graph 

Home or 
Device 

This workspace report displays a bar graph of the memory 
usage of a specific device in real time. The device must have 
Windows credentials specified in Device Properties > 
Credentials. You must configure this workspace report and 
select a device before any data is reported. 
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Split Second Graph workspace reports are displayed as either graphs or gauges. The 
workspace report picker specifies how the data is displayed within each Split Second Graph 
workspace report. For some types of performance data, you have several choices for how you 
can view the data. For example, real-time CPU utilization data is available in separate Split 
Second Graph workspace reports as a line graph, bar graph, or gauge. 

 

After you have decided what type of information you would like, and how you would like it 
displayed, you are ready to create a new workspace view and add individual workspace 
reports to this new view. 
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To create a new Split Second Graph workspace view: 
1 On the WhatsUp Gold web interface, select the Home tab. The Home Workspace 

appears. 
2 From the Workspace View list, select Manage Workspace Views. 

 
The Manage Workspace Views dialog appears. 

 
3 Click New. The New Workspace View dialog opens. 
4 Enter or select the appropriate information in the following fields. 

 Name. Enter Split Second Graphs. 

 Column count. We recommend that you leave the default column count of 2. 

 Column width. We recommend that you leave the default column width settings. 

5 Click OK to save changes. The new workspace view is added to the Manage Workspace 
View dialog. 

After you have created the new Split Second Graph workspace view, you can begin adding 
workspace reports. To add content to a workspace view, click the Add Content button 

. Select the content you want to add to your workspace view, then click OK. 

For more information on adding content to a workspace view, see Adding workspace reports 
to a workspace view in the Help. 
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Configuring Split Second Graph workspace reports 
You must configure each Split Second Graph workspace report that you add to a workspace 
view before any data is visible. In most cases, you will be required to choose a specific device 
for which you would like to view report data. 

To configure a workspace report, click Menu > Configure. For more information, see 
Configuring a workspace report in the Help. 

 

Troubleshooting Errors 
If a Split Second Graph workspace report displays "No Counters to Poll" in the graph, the 
device is not configured to collect data for the Performance Monitors that the Split Second 
Graph is attempting to use. 

 

In the graphic above, the CPU Utilization Performance Monitor is not configured for the 
device. To correct this, you must go to the Device Properties for the device and configure the 
CPU Utilization Performance Monitor.  

 Note: A device must have SNMP credentials and be SNMP-enabled for you to configure 
Performance Monitors.  

Move beyond the pre-configured workspace reports with the 
Performance Monitor workspace report 
If you want to display real-time data on areas not covered by the pre-configured Split Second 
Graph workspace reports, you can create your own using the Performance Monitor 
workspace report. This workspace report displays custom real-time graphs for an SNMP or 
WMI enabled device. Multiple SNMP and WMI counters can be specified for a single graph.  
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To use the Performance Monitor workspace report: 
1 In Web Performance Monitor, create and save the graph you want to use in the 

Performance Monitor workspace report. 

a) From the WhatsUp section of the GO menu, select Tools > Web Performance 
Monitor. The Web Performance Monitor appears. 

b) From the Graph menu, add the WMI and SMP counters that you want to graph. 

c) After the graph is configured to show the data you want to see in the Performance 
Monitor workspace report, select File > Save Graph as. The Save Graph dialog 
appears. 

d) Enter a name for the graph, then click OK. Your graph is saved and ready to use in the 
Performance Monitor workspace report. 

2 Add the Performance Monitor workspace report to a home workspace view. 

a) From any home workspace view, click Add Content. The Add Content to View dialog 
appears. 

b) Expand the Split Second Graphs section, select Performance Monitor, then click 
OK. The dialog closes and the home workspace view appears with the new 
Performance Monitor workspace report added. 

c) On the new Performance Monitor workspace report, click Menu > Configure. The 
Configure Line Chart dialog appears. 

d) In Graph name list, select the graph you created. You can optionally configure any 
other options on this dialog to your preferences.  

e) Click OK. The dialog closes and the home workspace view appears with your custom 
Web Performance Monitor graph displayed in the Performance Monitor workspace 
report. 

For information on building a graph for use within the Performance Monitor workspace 
report, see Using the Web Performance Monitor (on page 9). 
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Viewing Real-time Data in Full Reports 

For all full reports where real-time data is available, a second graph appears below the graph 
showing historical data. This second graph displays poll data for the report in real-time, 
updating every second. 
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About the Email Active Monitor with encryption and 
SMTP authentication 

This innovative monitor uses POP3 or IMAP to check mail servers by sending emails to an 
email address on the server and then validating that the emails are, in fact, received. If the 
emails are not received within a certain period of time, the mail server is considered down. 
The email active monitor supports encryption with SSL/TLS and SMTP Authentication which 
ensures that the monitor sends emails to a secure email account. 
 

Configuring an Email Active Monitor 

To configure an Email monitor: 
1 Go to the Active Monitor Library: 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Configure > Active Monitor Library. The Active 
Monitor Library appears. 

- or - 

 From the main menu of the console, select Configure > Active Monitor Library. The 
Active Monitor Library appears. 

2 Add an Email Monitor: 

a) Click New. The Select Active Monitor Type dialog appears.  

b) Select Email Monitor from the list, then click OK. The Add Email Monitor dialog 
appears. 

c) In Name, enter a title to identify this instance of the monitor.  

d) In Description, enter any additional information to further describe the monitor. 
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e) In the Outgoing mail section of the dialog, in SMTP server, enter the address of the 
server on which SMTP is running. Use the default, %Device.Address, to use the 
device IP address on which the monitor is attached. 

f) In Port, enter the port on which the SMTP service is listening. The standard SMTP port 
is 25. 

g) In Mail to, enter the address to which the Email Monitor will send email. 

h) In Mail from, enter the address from which the Email Monitor was sent from. 

i) In the Incoming mail section of the dialog, in Server, enter the address of the server 
on which the POP3 or IMAP service is running. 

j) In Account type, select the protocol (POP3 or IMAP) you want the monitor to use to 
check for correct email delivery. 

k) In Username, enter the username of the email account in which the monitor will use 
to log in. 

l) In Password, enter the password for the email account in which the monitor will use 
to log in. 

m) Click OK to add the monitor to the Active Monitor Library. 

If you want to configure advanced settings for this instance of the Email Monitor, click 
Advanced. From here, you can choose to use SMTP Authentication; set the port on which 
POP3 or IMAP is running; use encrypted connections for SMTP, IMAP, and POP3; and set 
timeouts for SMTP, IMAP, and POP3. 

3 Add the monitor to your mail server. 

a) On the device list, find the device that represents the mail server. Right-click the 
device, then select Properties. Select Active Monitors. 

b) Click Add. The Active Monitor Wizard appears. 

Select the monitor, and continue with the wizard to configure any actions for the 
monitor. 

For more information on setting up an action, see Configuring an action in the Help. 
 



 
 

CHAPTER 4 

Learning about Passive Monitor 
Features 
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In This Chapter 

Using device credentials for Passive Monitors......................................... 37
 
 

Using device credentials for Passive Monitors 

Passive Monitors, that require credentials, now use the device credentials that are stored in 
the credentials library.  

If you are assigning a Windows Event Log passive monitor type to a device, make sure that 
the device has credentials assigned before creating a passive monitor for it. If you want to use 
multiple Windows Event Log passive monitors, you must assign a unique Windows Event Log 
passive monitor for each device. For more information, see Using Credentials in the Help. 

 Note: The upgrade process to WhatsUp Gold v12 from previous versions, automatically 
migrates Windows Event Log passive monitor credentials into the Credentials Library.  

 If you experience upgrade problems with Windows Event Log passive monitors, look in the 
credentials library for the Windows (WMI) credentials that will work for the device. If the 
device credentials do not exist, create new credentials for the device. For more information, 
see Using Credentials in the Help. 
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Using high capacity SNMP interfaces 

High capacity counters were introduced in SNMPv2 to address the limitations of 32-bit 
counters for devices that track a large amount of data that the counter reaches its maximum 
value and wraps back to zero. WhatsUp Gold now includes high capacity (64-bit) counters to 
alleviate this by substantially increasing the size of the counter.  

This effect is evident in network interface utilization, where faster interface speeds cause 32-
bit counters to wrap so quickly that it is difficult to poll the counter frequently enough to not 
miss a counter wrap. 

Interface speed Time to wrap 

10Mbs ~ 57 minutes 

100Mbs ~ 5.7 minutes 

Gigabit (1Gbs) ~ 34 seconds 

With high capacity counters, it would require an interface operating at speeds of 1Tbs (1000 
Gbs) for roughly 5 years to wrap a counter. 
 

Configuring a high capacity SNMP interface 
Through this data stream, you can monitor and report on the SNMP interfaces on the current 
device. Data collected is displayed in the Interface Report.  

Use the following instructions to configure a high capacity SNMP interface. 

Step 1: Verify the device is using SNMPv2 or SNMPv3 credentials: 
1 Open the device properties for a device that supports high capacity counters for 

interface utilization.  
2 Select Credentials. The Credentials and SNMP dialog opens. 
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3 In SNMP v1/v2/v3 credentials, verify that the device is using an SNMPv2 or SNMPv3 
credential. If an SNMPv2 or SNMPv3 credential does not exist, you can create one by 
clicking the browse (...) button next to the field. 

 

Step 2: Configure a high capacity SNMP interface: 
1 In Device view, right-click on a device, then select Properties. 
2 In the Device Properties dialog, select Performance Monitors.  
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3 Select Interface Utilization, then click Configure. The Configure Interface Data 
Collection dialog appears. 

 
4 Select from the following options: 

 Collect data for list. Select the interfaces you want to gather data on.  

 All Interfaces or Active interfaces. Selects all interfaces in the list are selected 
automatically. Active interfaces collect data only for those interfaces that are currently 
in use.  

 Specific interfaces. Lets you select interface(s) from the Interface list.  

 Custom active interfaces. Lets you select custom interface(s) from which to collect 
data. A custom dialog opens to select custom interface options. 

 High speed interfaces (Gigabit or faster). Select this option to collect data from 
all custom active high speed interfaces. This is the default selection. 

 Name contains. Select this option to collect data from all custom active interfaces 
that contain the variable you enter. For example, if your network naming scheme 
includes a subgroup named customer, you would enter customer in the field to 
gather data from all interfaces for the subgroup that contain customer in the 
interface name.  

 Type is. Select this option and choose the interface type to collect data from all 
custom active interfaces of that type. 

 Data collection interval (minutes). Enter how often you want data to be collected for the 
selected item or items. This value represents the number of minutes between each 
collection. 

Click Advanced to access Data Collection Advanced Settings.  

  41 



 WhatsUp Gold v12.0 New Features Guide 

Click Speed to override the interface speed.  

 Important: You cannot change the speed for an interface until you have selected Specific 
Interfaces from the Collect data for drop-down menu. 

 

Using a high capacity SNMP interface 
After the high capacity interface utilization performance monitor is configured, you can use a 
performance monitor to watch interface utilization over time. The performance monitor 
creates a report that graphs the results of the monitor, allowing you to spot network device 
trends and patterns. 

To view high capacity SNMP data: 
1 From the main menu, select Reports > Device. The Device Reports category page 

opens. 
2 Select Interface Utilization. The Interface Utilization report page opens. 
3 If you have more than one custom performance monitor, verify that the correct monitor 

is listed under Select Interface. 

 

  42 



 WhatsUp Gold v12.0 New Features Guide 

The graph now shows the total utilization of the interface as a percentage of the interface's 
total capacity. The numbers graphed are derived from the high capacity counters. 

 Tip: Since the graph shows a percentage, you may prefer to modify Chart Properties so that 
the graph uses a Fixed Scale of 0 to 100. 

 

Using NetSNMP and UNIX CPU utilization 

This feature supports NetSNMP MIB counters for UNIX CPU utilization performance monitors.  
Now you can install the NetSNMP MIB on UNIX servers to monitor critical performance areas 
such as CPU utilization. There is no special installation required to use this feature. If a device 
uses an NetSNMP MIB to monitor CPU performance, select the CPU Utilization performance 
monitor for the device. 

Configure a NetSNMP agent for a Unix CPU utilization performance monitor: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Performance Monitors. The Performance Monitors dialog appears. 
3 In the Enable global performance monitors section, click to select the CPU Utilization 

option, then double-click CPU Utilization. The Configure CPU Utilization dialog 
appears. 

4 In the Collect data for list, select All CPUs, then click OK. 

 Note: If the Unix device has more than one CPU, all of the performance data will be shown as 
if there is only one CPU. 

 

Using a custom name for SNMP device interfaces 

This feature lets you rename SNMP device interfaces to help you manage network interfaces 
more efficiently and intuitively. Without this feature you must reference device interface 
names, on a router for example, by their default names. Often, the device interface names are 
not intuitive and it is difficult to determine the specific interface you are selecting when 
setting up an interface utilization monitor for performance monitors and active monitors. 
This feature also helps you easily select the interface you want to view in interface utilization 
performance reports and other applicable workspace reports and split second graphs. 
 

Configuring a custom name (ifAlias) for an SNMP device interface 
In order to configure a custom name (IfAlias) for a device's SNMP interface, you need to 
access the device configuration console and rename each interface according to your naming 
convention preference.  

After the interface(s) are renamed, you can add them as performance monitors and active 
monitors. You can also select the custom interface in various workspace reports and split 
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second graphs. If the device interface(s) already have performance monitors and/or active 
monitors set up, the new interface name displays in WhatsUp Gold accordingly. 

Use the following example instructions for how to change a Cisco router interface name. If 
you have other devices, refer to the device documentation for instructions on how to change 
interface names.  

To configure a device custom name for an SNMP interface on a Cisco router: 

 Open the Cisco Command Line Interface (CLI) and enter the following commands: 

Cisco1812# configure 

Cisco1812(config)# interface FastEthernet 9 

Cisco1812(config-if)# description CUSTOM NAME 

Cisco1812(config-if)# ^Z 

Cisco1812# 

To add a Performance Monitor for a newly renamed device interface: 
1 On the Devices tab, in Device View or Map View, right-click a device, then click 

Properties. The Device Properties dialog appears. 
2 Click Performance Monitors. The Performance Monitors dialog appears. 
3 In the Enable global performance monitors section, click to select the Interface 

Utilization option, then click Configure. The Configure Interface Data Collection dialog 
appears. 
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4 In the Collect data for list, select Specific Interfaces. In this example, CUSTOM NAME is 
the interface name created for the Cisco router. Click to select CUSTOM NAME, then 
click OK. 

 
5 Click OK, then click Close to close the Device Properties dialog. 

To add an Active Monitor for a newly renamed device interface: 
1 In the console application, on the Device View or Map View tab, right-click a device, 

then click Properties. The Device Properties dialog appears. 
2 Click Active Monitors. The Active Monitors dialog appears. 

 Important: If a device has active monitors set up prior to renaming the device's interface(s), 
then after renaming the device's interface(s), remove the old interface(s) from the Active 
Monitor dialog, then click Discover to refresh the device interface list. Use the console 
application for the discover process.  
If a device has performance monitors set up prior to renaming the device's interface(s), the 
device interface names are automatically updated. 

3 (Optional) If a device has active monitors set up for a device prior to renaming the 
device's interface(s), select the interface(s) that you renamed from the list of interfaces, 
then click Remove. 
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4 (Optional) Click Discover. The interface list refreshes and populates with the new 
interface names in the Comment list. 

 
5 Click OK, then click Close to close the Device Properties dialog. 

To select a newly renamed device interface for the Interface Utilization report: 
1 From the WhatsUp section of the GO menu, select Reports > Performance. The 

Performance Reports list appears. 
2 Under the Device category, click Interface Utilization. An Interface Utilization report 

appears. 

 
3 Click the device name/IP address (shown above) to select the device you want to view. 

The Select a Device dialog appears. 
4 Expand the network tree list to view the SNMPScan devices, then select the device for 

which you want to view the Interface Utilization report. The Interface Utilization report 
appears. 
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5 In the Select Interface list, select the newly named device interface. In this example, the 
interface is named CUSTOM NAME. View the interface utilization report. 
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About SMS notifications 

Short Message Service (SMS) is similar to paging. Often called text messaging, SMS sends 
short alpha-numeric messages to and from mobile phones and handheld devices.  

There are two types of SMS notifications, SMS and SMS Direct:  

 SMS notifications require an SMS provider. An SMS provider is a business entity that 
provides SMS messaging services but is not a mobile network operator (such as T-Mobile). 
This provider attempts to send messages to mobile phones and handhelds. If a phone or 
handheld is not active, or is out of range, the service holds the message until the phone is 
active again.  

 SMS Direct notifications do not require an SMS provider, but do require that the phone it 
is attempting to send messages to be active and within range.  

SMS notifications are sent in one of two ways: email, where a specifically formatted email 
message is sent to an email address, or dialup, the protocol used in many pagers which 
requires a modem and the phone number of the recipient.  

Because multiple methods can be used to send SMS notifications, there are no common 
settings other than messages may not exceed 160 alpha-numeric characters. 

WhatsUp Gold can send both SMS and SMS Direct notifications through Actions. 
 

Creating an SMS Direct Action 

To create an SMS Direct Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 
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 On the WhatsUp section, select Configure > Action Library. The Action Library 
appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select SMS Direct. 

- or - 

 Select an existing SMS Direct Action, then click Edit. 

The action properties page appears. 

3 Set the appropriate options. 

 Name. Enter a name for this notification. This name is for your reference only and will 
never be displayed to the notification recipient. 

 Description. Enter or modify the description. This description appears in the Action 
Library and is for your reference only. 

 Phone number. Enter the cell phone number(s) of the intended SMS message 
recipients. You can enter multiple phone numbers, separated by a comma. For 
example: 555-555-5555, 55 555 55 55 55, (555) 555 5555 

 Note: All non-numeric characters other than the comma, such as "-" and ".", will be ignored. 

There is a 2,000 character limit in this field, so you can enter many numbers. 

 COM Port. Select the COM port you want to use with this notification. 

 Note: The list displays all ports associated with the GSM modem, including virtual and hard-
wired, serial ports. You must select the port that is assigned to the modem in the Windows 
Device Manager.  

 Message. Enter the text message you want to send with this notification plus any 
desired percent variable codes. Keep in mind that if you use percent variables, this will 
greatly increase the character count. 

 Note: If the message exceeds 140 characters, the message may be broken into up to 3 parts 
and will be sent as separate messages ("1 of 3", "1 of 2", etc.), each message containing up to 
140 characters, for a total of up to 420 characters. Spaces are counted in the total number of 
characters.  

4 Click OK to save this action. The action now appears in the Action Library. 
5 Assign the action to a device or a monitor, by using the procedure defined in: 

 Assigning an action to a device (on page 51) 

 Assigning an action to a monitor (on page 51) 
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Assigning an action to a device 
You can assign one or more individual actions to a device, or assign an action policy that may 
contain multiple actions used across your device list. 

To assign actions to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Actions. The Actions dialog appears. 
3 Select the Apply individual actions option. 
4 Click Add to access the Action Builder wizard. 
5 Follow the directions in the Action Builder wizard. 
6 At the end of the wizard, click Finish to add the action to the device. 
7 If you need to add more actions to the device, click Add and repeat these directions. 
8 When you have completed adding actions, click OK. 

To assign an action policy to a device: 
1 Right-click a device, then click Properties. The Device Properties dialog appears. 
2 Click Actions. The Actions dialog appears. 
3 Select the Apply this Action Policy option. 
4 Select the action policy you want to use for this device. If you need to create a new 

action policy first, click Add to access the Action Builder dialog. 
5 Click OK to save the changes. 

After an action has been added to the device, the action fires when that device reaches the 
specified state. 
 

Assigning an action to a monitor 
You can assign one or more individual actions to a monitor, or assign an action policy that 
may contain multiple actions. 

To assign an action to an active monitor: 

 Note: During the configuration of a new monitor, you are presented with the Action Builder 
as part of the wizard. The following set of directions is for existing monitors. 

1 Right-click the device the active monitor is configured on, then click Properties. The 
Device Properties dialog appears. 

2 Click Active Monitors. The Active Monitors dialog appears. 
3 Double-click the monitor on which you want to add actions.  
4 Go to the actions properties: 

 From the web interface, in the Active Monitor Properties wizard, click Next. 

- or - 

From the console, in the Active Monitor Properties dialog, select Actions. 

5 Select the Apply individual actions option. 
6 Click Add to access the Action Builder wizard. 
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7 Follow the directions in the Action Builder wizard. 
8 At the end of the wizard, click Finish to add the action to the monitor. 
9 If you need to add more actions to the monitor, click Add and repeat these directions. 
10 Click OK after all actions have been added. 

To assign an action policy to an active monitor: 

 Note: During the configuration of a new device, you are presented with the Action Builder as 
part of the wizard. The following instructions are for existing devices. 

1 Right-click the device on which the active monitor is configured, then click Properties. 
The Device Properties dialog appears. 

2 Click Active Monitors. The Active Monitors dialog appears. 
3 Double-click the monitor on which you want to add actions.  
4 Go to the actions properties: 

 From the web interface, in the Active Monitor Properties wizard, click Next. 

- or - 

From the console, in the Active Monitor Properties dialog, select Actions. 

5 Select the Apply this Action Policy option. 
6 Select the action policy you want to use for this device. If you need to create a new 

action policy first, click the browse button to access the Action Policies dialog. 
7 Click OK to save the changes. 

To assign an action to a passive monitor: 
1 Right-click the device the on which the passive monitor is configured, then click 

Properties. The Device Properties dialog appears. 
2 Click Passive Monitors.  
3 Double-click the monitor on which you want to add actions. The Passive Monitor 

Properties appear. 
4 Go to the actions properties: 

 From the web interface, in the Passive Monitor Properties wizard, click Next. 

- or - 

From the console, the Passive Monitor dialog appears. 

5 Click Add to access the Action Builder wizard. 
6 Follow the directions in the Action Builder wizard. 
7 At the end of the wizard, click Finish to add the action to the monitor. 
8 If you need to add more actions to the monitor, click Add and repeat these directions. 
9 Click OK after all actions have been added. 

 Note: You cannot assign an action policy to a passive monitor. 

After an action has been added to the monitor, the action fires when that state reaches the 
assigned down state. 
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Recommended SMS modems and  
troubleshooting tips 

Ipswitch has tested and currently recommends the following SMS modems for use with the 
SMS Direct Action (not the SMS Action): 

 Motorola® RAZR V3 (http://www.motorola.com) 

This cell phone was connected to the WhatsUp device acting as a GSM modem.  

 MultiModem® GPRS external wireless modem 
(http://www.multitech.com/PRODUCTS/Families/MultiModemGPRS/), model: MTCBA-G-
F2 

 Siemens TC65 Terminal (http://www.usa.siemens.com) 

Unlike the other modems that have their own drivers to install, this modem did not have 
specific drivers to install. The Windows Standard 56000 bps modem driver was used with 
the maximum port speed set to 115200.  

 Falcom Samba 75 (http://www.falcomusa.com) 

To consider 
 GSM networks operate in the 850/900/1800/1900 Mhz bands. 

 GSM modems are typically either dual or quad band. 

 Note: You must acquire a dual modem that operates at the correct frequency, or purchase a 
quad band modem. 

 European markets typically use 900/1800 Mhz capable devices. 

 The U.S. and Canada use 850/1900 Mhz capable devices. 

Troubleshooting SMS Modems 
If an SMS modem is not working as expected, verify that the communications port (COM port) 
to which the modem is attached is configured to use settings supported by the modem. 

1 In the Windows Control Panel, double-click Device Manager. The Device Manager 
appears. 

2 Expand Ports. 
3 Double-click the communications port used by the SMS modem. The Communications 

Port Properties dialog appears. 
4 Select the Port Settings tab. 
5 Using the documentation provided by the modem manufacturer, verify that the port 

settings listed are supported by the modem. If the listed settings are not supported, 
make any necessary changes. 

6 Click OK to save changes. 
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Using line feeds and carriage returns to correct SMS modem issues 
Some SMS Direct enabled phones do not work correctly with SMS Direct Actions because 
new line characters are not always handled properly. This issue may be corrected by adding 
the following new registry key entry: 

HKEY_LOCAL_MACHINE\SOFTWARE\Ipswitch\Network Monitor\Whatsup 
Plugins\Actions\ActSmsDirect\NewLine  

In the Value data box, enter a combination of a carriage return (\r) and/or line feed (\n) 
command. For example enter one of the following: 

 newline \r\n (recommended) 

 newline \r 

 newline \n 
 

About SMTP authentication for email actions 

The SMTP authentication for email actions feature provides the capability to set up actions 
and send email alerts to mail servers that require valid SMTP authentication. With this feature, 
WhatsUp Gold can provide email access control resulting in support for IT environments with 
more stringent security requirements. 
 

Creating an Email Action 
To create an Email Action: 
1 Go to the Action Library: 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Configure > Action Library. The Action Library 
appears. 

- or - 

 From the main menu bar of the console, select Configure > Action Library. The 
Action Library appears. 

2 In the Action Library, do one of the following: 

 Click New, then select Email Action. 

- or - 

 Select an existing Email Action, then click Edit. 
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The action properties page appears. 

 
3 Enter the email destination information. 

 Name. Enter a unique name for this action. 

 Description. Enter a short description of the action. This is displayed in the Action 
Library along with the entry in Name. 

 SMTP Mail Server. Enter the IP address or Host (DNS) name of your email server 
(SMTP mail host). 

 Port. Enter the port number that the SMTP server is installed on. 

 Timeout. Enter the amount of time (in seconds) to wait for user authentication on the 
SMTP server. The authentication fails if this time limit is exceeded. 

 Mail To. Enter the email addresses you want to send the alert to. Email addresses 
must be fully qualified. You can enter two addresses, separated by commas (but no 
spaces). The address should not contain brackets, braces, quotes, or parentheses. 
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 SMTP server requires authentication. Check this option if your SMTP server uses 
authentication. This enables the Username and Password fields. 

The Email action supports three authentication types: 

 CRAM-MD5 

 login 

 plain 

The authentication type is not configurable. It is negotiated with the SMTP server 
automatically. 

 Username. Enter the username to be used with SMTP authentication. 

 Password. Enter the password of the username to be used with authentication. 

 Use an encrypted connection (SSL/TLS). Check this option if your SMTP server 
requires the data to be encrypted over a TLS connection (formerly known as SSL). 

4 Click Mail Content. Enter the content of the email alert. 

 From. Enter the email address that will appear in the From field of the email that is 
sent by the Email action. 

 Subject. Enter a text message or edit the default message. You can use percent 
variable codes to display specific information in the subject. 

 Message body. Enter a text message or edit the default message. You can use 
percent variable codes to display specific information in the message body. 

5 Click OK to save this action. The action now appears in the Action Library. 
6 Assign the action to a device or a monitor. For more information, see Assigning an action 

to a device (on page 51) or Assigning an action to a monitor (on page 51). 
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CHAPTER 7 

Learning about SNMP Features 
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About the SNMP Management Information Base 
(MIB) 

The MIB contains the essential objects that make up the management information for a 
device. The Internet TCP/IP MIB, commonly referred to as MIB-II, defines the network objects 
to be managed for a TCP/IP network and provides a standard format for each object. 

The MIB is structured as a hierarchical object tree divided into logically related groups of 
objects. For example, MIB-II contains the following groups of objects: 

 System. Contains general information about the device, for example: sysDescr 
(description), sysContact (person responsible), and sysName (device name). 

 Interfaces. Contains information about network interfaces, such as Ethernet adapters, or 
point-to-point links; for example: ifDescr (name), ifOperStatus (status), ifPhysAddress 
(physical address), ifInOctets, and ifOutOctets (number of octets received and sent by the 
interface). 

 IP. Contains information about IP packet processing, such as routing table information: 
ipRouteDest (the destination), and ipRouteNextHop (the next hop of the route entry). 

 Other groups provide information about the operation of a specific protocol, for 
example, TCP, UDP, ICMP, SNMP, and EGP. 

 The enterprise group contains vendor-provided objects that are extensions to the 
MIB. 

Each object of the MIB is identified by a numeric object identifier (OID) and each OID can be 
referred to by its text label. For example, the system group contains an object named 
sysDescr, which provides a description of the device. The sysDescr object has the following 
object identifier: 

iso.org.dod.Internet.mgmt.mib.system.sysDescr 

1.3.6.1.2.1.1.1  

This object identifier would be 1.3.6.1.2.1.1.1 to which is appended an instance sub-
identifier of 0. That is, 1.3.6.1.2.1.1.1.0 identifies the one and only instance of sysDescr. 
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All of the MIB-II objects (for TCP/IP networks) are under the "mib" sub tree (so all these objects 
will have an identifier that starts with 1.3.6.1.2.1). 

For a detailed description of the MIB, see RFC 1213. 
 

Using and importing MIBs into WhatsUp Gold 
WhatsUp Gold includes a variety of common MIB files, including a number of Cisco MIBs. If a 
particular MIB file is not included in the WhatsUp Gold MIB Library, WhatsUp Gold lets you 
import a MIB for use in the application. You can import files with no extension, or the 
following extensions: 

 .txt 

 .my 

 .mib 

We also provide a library of common MIB files on the WhatsUp Gold Web site on the WhatsUp 
Gold Web site WhatsUp Gold Web site (http://www.whatsupgold.com/resources/mib.asp). 

To import a MIB file into WhatsUp Gold: 
1 Add the MIB files to the WhatsUp Gold MIB directory: 

On the directory that WhatsUp Gold is installed, copy the MIB file to: 

Program Files > Ipswitch > WhatsUp > Data > Mibs 

2 Restart: 

 the WhatsUp Gold console 

 the WhatsUp Gold Web server 

 the Ipswitch WhatsUp Engine service 

If you have problems when trying to use the MIB, you should validate the MIB file. At this time 
Ipswitch does not provide a MIB validation program, but various validators are available for 
download. See the KB article, MIB file import and MIB file error checking (To import a MIB file 
into WhatsUp Gold:) for more information. 

 Important: If you are importing a file that has a dependency to other MIB files, you should 
import these files also. Dependencies are defined at the beginning of the file, in the 
"IMPORTS" section. 

 

Using the SNMP MIB Walker 
This network tool lets you discover, or explore in detail, the SNMP objects that a device 
supports and that can be monitored with WhatsUp Gold. The SNMP MIB Walker actively polls 
for objects. It does not require MIB files for the polled objects to be loaded. 

An SNMP walk is a succession of SNMP getnext reads starting with the configured Object ID 
(the root of the subtree walked) until there are no next objects in the MIB subtree or until the 
specified number of lines in the MIB have been walked. As results return from the MIB Walker, 
you can click an object (node) for more detailed information about the SNMP object and to 
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walk further down the list of objects. You can also hover the mouse cursor over a node to 
display SNMP object details. 

To use the SNMP MIB Walker: 
1 Enter or select the appropriate information in the following fields. 

 Address or hostname. Enter an IP address hostname for the device. 

 Credentials. Select the appropriate credentials for the device from the list. For more 
information, see Using Credentials in the Help. 

 Object ID. Enter the numeric or label ID for the object for which you want 
information. A default OID is displayed in the box. 

 Filter. (Optional) Enter a filter to narrow down the search by returning only OIDs 
whose values match the filter criteria.  

 Tip: This is a regular expression, non-case-sensitive filter. For more information, see Regular 
Expression Syntax in the Help. 

 Click the Advanced button to change the value for the search timeout and retries, 
output types (tree, list-numeric OIDs, list-labels), and the maximum number of lines 
displayed. 

2 After you have entered all of the information, click Walk to perform the search. The 
SNMP MIB Walker returns a list of SNMP objects that are available on the selected 
device. 

 

  59 



 WhatsUp Gold v12.0 New Features Guide 

To cease the walk, click Stop. If you are performing multiple walks, click Back to view the 
previous walk. 

After the SNMP Walker returns a list of the supported SNMP objects, you can use this 
information to create custom performance monitors and active script performance monitors 
for devices. For more information, see Adding Custom Performance Monitors to Devices in the 
Help. 

To view detailed information about a specific MIB object, mouse over the object for which 
you need more information. The information displays in a popup bubble. 

   

About MIB Output Types 
You can change the format for the way MIB objects are displayed in the Advanced 
Parameters dialog. Whether the OID information is output as numeric OIDs or descriptive 
labels, each node may have additional sub-nodes that can be drilled down (walked) for more 
information. Each time you click a node, if there are child nodes, the node you clicked 
becomes the root node for the drill-down. The child nodes are expanded and attributes are 
displayed. MIB objects can be listed in one of three format options: 

 Tree. Lists the MIB object in a tree structure format. This format is most useful in showing 
the OID hierarchy. 
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 List - Numeric OIDs. Lists the objects in a tabular format showing OIDs in a row numeric 
format. This format is especially helpful if you do not have the MIB file for the device 
objects. It provides the raw OID information that you can use in Custom Performance 
Monitors and Active Script Peformance Monitors. Also, you can click the individual OID 
digits to display more or less MIB object information. As you click OID digits, the digits 
further to the left expand the sub-node information of the respective digits. As you click 
OID digits further to the right, the sub-node information expands for the respective digit 
and therefore more granular sub-node information. 

 List - Labels. Lists the objects in a tabular format with user friendly labels. If the MIB for 
the object is not loaded, labels will default to numeric OIDs. Click an OID label name to 
expand the sub-nodes and view more information. 

 Note: You can switch to the WhatsUp Gold MIB Explorer by clicking on the MIB Explorer link 
on the upper-right side of this dialog. 

 

Using the SNMP MIB Explorer 
This network tool lets you search for, or explore through, SNMP objects defined in MIB files. 
The MIB File Explorer has three search/explore options. 

As results return from the MIB File Explorer you can click an object (node) for more detailed 
information about the SNMP object. You can also hover the mouse cursor over a node to 
display SNMP object details. 

To search by object ID: 

 Enter an object label or object ID in the Object ID field, then click Detail. 

To search by MIB module: 

 Select a module from the MIB Module list, then click Display. 

To search objects by type or description: 

 First select Type or Description from the Search Object list. Then proceed appropriately: 

 To search by object Type: 

 Select a type from the list, then click Find. 

 To search by object Description: 
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 Enter a regular expression in the Description field. This is a regular expression, 
non-case-sensitive filter. For more information, see Regular Expression Syntax in 
the Help. After entering the description in the field, click Find. 

 

After the MIB File Explorer returns a list of the supported MIB objects, you can use this 
information to create custom performance monitors and active script performance monitors 
for devices. For more information, see Adding custom performance monitors to devices in the 
Help. 

 Note: You can switch to the WhatsUp Gold MIB Walker by clicking on the MIB Walker link on 
the upper-right side of this dialog. 

 

Using the SNMP MIB Manager 
The SNMP MIB Manager provides a list of all of the MIB files installed in the WhatsUp Gold MIB 
directory. Using this tool, you can import new MIB files to the MIB Manager. SNMP MIB 
Manager validates imported MIB files and flags errors if there is a problem with a file. 

To use the SNMP MIB Manager: 
1 Go to the SNMP MIB Manager. 

 From the web interface, click GO. The GO menu appears. 

 On the WhatsUp section, select Configure > SNMP MIB Manager. The SNMP MIB 
Manager dialog opens. 
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2 Use the following options in the SNMP MIB Manager: 

 View. Select a MIB file in the list, then click View to open the MIB and view the code. 

 Add. Click Add to import a MIB file to the MIB Manager. Follow the dialogs to 
complete the process. 

 Note: If you need to add a large number of MIB files, you can manually copy them to the 
\Program Files\Ipswitch\WhatsUp\Data\Mibs\ directory, then click Reload in the 
SNMP MIB Manager dialog to update and validate their status. 

 Reload. When you import a new MIB file or are troubleshooting code in a MIB file, 
click Reload to refresh the MIB Module list and the Status list. 

 

Using the SNMP API 

The WhatsUp Gold SNMP COM API has been enhanced to improve the performance of your 
scripted monitors and actions. With the addition of GetMultiple, you have the ability to get 
multiple OID's within a single SNMP request. GetNext issues the SNMP GetNext command to 
retrieve the value of the object that follows a specified object. Finally, the addition of the 
SetFunction allows you to send SNMP set commands to your SNMP manageable devices. 

The SNMP API includes the following objects: 

 CoreAsp.SnmpRqst. The main SNMP object used to send SNMP requests (Get, GetNext, 
Set) to a remote device. 

 CoreAsp.ComResult. An object returned by certain methods of the SnmpRqst object to 
indicate success or failure. 

 CoreAsp.ComResponse. A response object returned by certain methods of the 
SnmpRqst object that contain the status (either error or success) of an SNMP request and 
the value of the polled object(s). 

 

CoreAsp.SnmpRqst 
This object is used to send SNMP requests to a remote device. 

Initialize or Initialize2 must be called prior to any other members. 

CoreAsp.SnmpRqst uses a three step process: 

1 Calls Initialize or Initialize2 to initialize the object against a particular device. 
2 Sets optional parameters such as timeout value, port, etc. 
3 Performs any number of Get, GetNext, GetMultiple or Set operations against a 

device. Those operations return an ComSnmpResponse object that contains the status 
of the operation and the value either directly (use Failed/GetValue/GetOid) or as a 
list of SNMP variable binding returned as XML data (use GetPayload). 
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Method Description Returns 

Initialize(  
   nDeviceID  
) 

Initializes the SnmpRqst object for the device with 
the device ID specified in nDeviceID. If a device is 
not configured with a valid SNMP credential, the 
operation will fail.  

 nDeviceID. A positive integer 
corresponding to the device ID of a device 
configured in WhatsUp Gold. 

Tip: In Active Script Monitor and Script 
Performance Monitors, the device ID of the 
device to which the monitor is assigned can be 
obtained from the Context object: 
Context.GetProperty("DeviceID")  

ComResult object  

Initialize2( 
   sDeviceAddress, 
   nCredentialID  
) 

Initializes the SnmpRqst object by creating a 
connection to a device using the IP address of a 
device and a credential stored in WhatsUp Gold. This 
method can be used to initialize SnmpRqst for a 
device that is not configured in WhatsUp Gold as 
long as the credentials for the device are configured 
in the credential library. 

 sDeviceAddress. The address or hostname 
of the device to be queried. 

 nCredentialID. A positive integer 
corresponding to the credential ID of a 
credential configured in WhatsUp Gold. 

ComResult object  

SetTimeoutMs( 
   
nTimeoutInMilliSec 
) 

Sets the timeout value in milliseconds. If not 
specified, the timeout defaults to 2000 milliseconds. 

 nTimeoutInMilliSec. A positive integer 
representing the number of milliseconds 
after which unresolved requests should be 
terminated. 

ComResult object  

SetNumRetries( 
   nNumberRetries 
) 

Sets the number of times to retry a request that has 
timed out. If not specified, failed requests are retried 
one time.  

 nNumberRetries. A positive integer 
representing the number of times to retry 
timed out requests. 

Tip: To send only one SNMP packet per request, 
set nNumberRetries to 0 (zero). 

ComResult object  

SetPort( 
   nPort 
) 

Sets the TCP/IP port to be used by SnmpRqst. If not 
specified, port 161 is used. 

 nPort. A positive integer between 1 and 
65535 corresponding to the port to be used. 

ComResult object  
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Method Description Returns 

Get( 
   sOid 
) 

Issues an SNMP Get command to retrieve the value 
of the specified object. 

 sOid. A string containing a valid OID. 

ComSnmpResponse 
object 

GetNext( 
   sOid 
) 

Issues an SNMP GetNext command to retrieve the 
value of the object that follows the specified object 
in lexicographic order. 

 sOid. A string containing a valid OID. 

ComSnmpResponse 
object 

GetMultiple( 
   sListOfOids 
) 

Issues an SNMP Get command for each of the objects 
specified. GetMultiple sends all commands in a 
single SNMP protocol data unit, so it is more efficient 
than issuing multiple Get commands independently. 

 sListOfOids. A comma-separated list of 
valid OIDs. 

ComSnmpResponse 
object 

Set( 
   sOid, 
   sType, 
   sValue 
) 

Issues an SNMP Set command to set an OID value on 
a device. 

 sOid. A string containing a valid OID for the 
object for which you want to set the value. 

 sType. A single character corresponding to 
the type of value to set. 

i = integer 

u = unsigned integer 

s = string 

x = hexadecimal string 

d = decimal string 

n = NULL object 

o = object ID 

t = timeticks 

a = IPv4 address 

b = bits 

 sValue. A string containing the value to set. 

ComSnmpResponse 
object 

 
 

CoreAsp.ComResult 
This object is returned by members of the SnmpRqst object or other objects to indicate the 
status of an operation. 

Member Description 

Failed Returns true if this object contains a failure and false if the object contains a 
success. 
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GetErrorMsg If Failed is true, this member returns the associated error message. 

 Note: All the members of the ComResult object are methods. They have no arguments and 
should be called without parenthesis.  

 

CoreAsp.ComSnmpResponse 
This object contains a response from an SNMP request. It is returned by SnmpRqst member 
functions: Get, GetNext, GetMultiple and Set. 

Member Description 

GetOid Returns the OID of the polled object. This member cannot be used with operations 
that poll multiple objects, such as SnmpRqst.GetMultiple. 

Note: This member is only useful when used with SnmpRqst.GetNext. It can 
be used with SnmpRqst.Get and SnmpRqst.Set, but it returns the same 
OID that you specified when calling those functions. 

GetValue Returns the value of the polled object. This member can only be used with functions 
that poll a single object (SnmpRqst.Get, SnmpRqst.GetNext and SnmpRqst.Set) 

Failed If the request succeeded, returns false. If the request failed, returns true. 

Note: When polling multiple objects, Failed returns true if even one error 
exists in the results returned by GetPayload. 

GetErrorMsg If Failed returns true, this member returns the associated error message. 

GetPayload Returns XML data describing SNMP variable bindings (each containing OID, Type 
and Value).  

This XML data consists of a single VarBindList node which contains one or many 
SnmpVarBind nodes.  

<VarBindList> 
   <SnmpVarBind bHasError="false" sError="" 
sOid="1.3.6.1.2.1.1.1.0" sValue="HELLO" /> 
   <SnmpVarBind bHasError="false" sError="" 
sOid="1.3.6.1.2.1.1.1.1" sValue="WORLD" /> 
</VarBindList> 

You can use the Microsoft XML DOM object to access this information. For more 
information, see the Read multiple objects in one request example in the Help 

 Note: All the members of the ComSnmpResponse object are methods. They have no 
arguments and should be called without using parenthesis. 
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In This Chapter 

Organizing Devices, Device Groups, and Maps with drag-and-drop   67
 
 

Organizing Devices, Device Groups, and Maps with 
drag-and-drop 

In the Device and Map views, you can quickly and easily organize your devices and device 
groups by dragging the device you want in a particular group to the device group folder.  
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After you drop the icon or icons, a menu appears, asking if you want to move or copy the 
devices. If you move the devices, they are deleted from the previous device group. If you 
copy the devices, the devices appear in both device groups. 

 Note: When you copy a device using drag-and-drop, a shortcut is created in the new 
location. Even though a device exists in multiple locations, it only exists once in the database. 
Therefore, to modify a device, you can change the settings by opening the device properties 
from any group in which the device appears, and the change is reflected in all other 
instances of the device. This also means that each device is only polled once, no matter how 
many times it appears in your device group tree. 
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Windows Vista Support 

WhatsUp Gold now includes full support for Microsoft Vista both as a monitored OS and as 
the WhatsUp Gold host system. Windows Vista Ultimate and Windows Vista Business 
(Windows Vista SP1 recommended) are supported. 
 

About the SQL Server 2005 Express Database 

The WhatsUp Gold installation program installs the SQL Server Express Edition (SSEE) 
database server and configures the WhatsUp database. SSEE provides several benefits over 
Microsoft SQL Desktop Engine (MSDE 2000), which was used by previous versions of 
WhatsUp Gold. 

SSEE provides the following benefits over MSDE 2000: 

 Doubles database size limit from 2 GB to 4 GB. 

 Removes workload governor, greatly improving database performance. 

 Supports Microsoft Windows Vista.  

 Support for SQL Server 2005 as a database. 

For more information, see the Microsoft SQL Server Express Web site 
(http://www.microsoft.com/sql/editions/express/default.mspx). 
 

Updated Web User Interface 

WhatsUp Gold includes an updated web interface, with a Windows Vista look-n-feel, that 
provides simple navigation and rapid access to information from anywhere, at any time. 
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Ipswitch Dashboard Screen Manager Overview 

The Dashboard Screen Manager is a stand-alone application designed to display a series of 
Web pages, or a "playlist," on one or multiple monitors. The Dashboard was created as a 
complement to the Ipswitch network monitoring application, WhatsUp Gold, and as an aid to 
keeping your network visible. The Dashboard application is included in WhatsUp Gold 
Premium Edition and the Central and Remote Site installations. 

The Dashboard can run on a display console and cycle through various pages from the 
WhatsUp Gold web interface. Network administrators then have important and pertinent 
network information on display at all times, cycling and changing on its own without the 
need of constant configuration. It also provides the capability to view multiple networks that 
you are monitoring simultaneously. 

Though the Dashboard Screen Manager was created to work along-side WhatsUp Gold, it can 
display virtually any Web page. For example, an Internet business providing service to a small 
town in the desert glances at one screen on the Dashboard and sees that the connectivity to 
the town is down. By displaying the weather for this town on another screen at the same 
time, the network administrator is able to see that the extreme temperatures of the day have 
likely caused problems for the cable transmitters. 

 Note: If you want to display a password protected page for another Web application, you 
must supply a valid username and password for the page. For more information, see the 
Dashboard application Help. 

For more information about the Dashboard playlists, see Configuring a Dashboard Playlist (on 
page 71). 

For more information about configuring a multi-monitor network display, see Setting up a 
WhatsUp Multi-Monitor Network Display, located on the Ipswitch Network Monitoring Web site 
(http://www.whatsupgold.com/). 
 

How does the Dashboard Screen Manager work? 
In order for the Dashboard to work, it needs: 

1 A monitor, or several monitors 
2 A playlist for each monitor 

The Dashboard displays a single playlist on every monitor you configure for use with the 
Dashboard. You can configure as many monitors as you would like for use with the 
Dashboard. 

  70 

http://www.whatsupgold.com/


 WhatsUp Gold v12.0 New Features Guide 

What is a Dashboard playlist? 
On the Dashboard Screen Manager, a playlist is a list of Web pages the Dashboard displays on 
a single monitor. A playlist can consist of one single, or multiple Web pages. When a playlist is 
configured with a single Web page, this single page is refreshed on a user-specified refresh 
interval. When a playlist is configured with multiple Web pages, the playlist cycles through 
the pages also on a user-specified interval. 
 

Opening the Dashboard Screen Manager 
After successfully installing the Dashboard, you can access the application from your 
Windows Start Menu by selecting Ipswitch Dashboard > Dashboard. 

 Note: This changes if after the initial setup of the Dashboard, you choose to run the 
Dashboard at Startup (on the Dashboard Settings dialog). If you choose to do so, the 
Dashboard Screen Manager will automatically take you to the blank screen discussed below. 

When the dashboard first opens, a blank screen is displayed. The blank page's title bar reads, 
"Ipswitch Dashboard [Configure the 'Playlist' for the Dashboard by clicking a mouse button] - 
aboutblank." 

If you have multiple displays, you will see a Dashboard application instance for each display 
in the taskbar. For example, if you have three display devices, DISPLAY1, DISPLAY2, or 
DISPLAY3 shows in the taskbar. Select the display you want to configure first, then click a 
button on your mouse to open the Dashboard Operations dialog. From here, you can 
configure Dashboard playlists (on page 71). 
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Configuring a Dashboard Screen Manager playlist 
Keep in mind that you need to set up a playlist for each physical monitor on which you want 
to display Web pages through the Dashboard Screen Manager.  

To configure a single Web page playlist: 

If you have chosen not to run the Dashboard Screen Manager upon Startup, click Start > 
Programs > Ipswitch Dashboard > Dashboard. The Dashboard Operations dialog appears. 

- or - 

If you have chosen to run the Dashboard Screen Manager upon Startup, on the display you 
want to configure a playlist for, click on the screen and the Dashboard Operations dialog 
appears.  

1 On the Dashboard Operations dialog, select Playlist for this Monitor. The Pane 
Properties dialog appears. 

 
2 Select Display single Web page. 
3 Enter the appropriate information in the following fields: 

 Title bar text. Enter the title bar name for the Dashboard display. 

 URL. Enter or paste the URL for the Web page you want to display in the following 
format: 

http://www.websitename.com/webpagename 

 Refresh interval (in seconds). Enter an amount of time (in seconds) for how often 
you would like the Web page to refresh. 

 WhatsUp Gold Web login. Either select a user from the drop-down list, or click the 
browse (...) button to choose a user from the WhatsUp Gold Web Login Library. This 
user account is used for the Dashboard application to log-in to a password protected 
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site. Without a proper user account, the application is not able to display a password-
protected Web page. If you are using a non-WhatsUp Gold Web page, set the Web 
login to None. 

 Note: Other applications requiring a username and password to display Web pages can be 
used in the Dashboard Screen Manager. You can specify these other application username 
and passwords in the URL field, appended to the Web page URL. 

4 Click OK to save changes. 

 Important: The Web Login drop-down list is empty until you populate the Web Login Library 
with users. You can do this via the Web Login Library dialog. 

To configure a multiple Web page playlist: 

If you have chosen not to run the Dashboard Screen Manager upon Startup, click Start > 
Programs > Ipswitch Dashboard > Dashboard. The Dashboard Operations dialog appears. 

- or - 

If you have chosen to run the Dashboard Screen Manager upon Startup, on the display you 
want to configure a playlist for, click on the screen and the Dashboard Operations dialog 
appears.  

1 On the Dashboard Operations dialog, select Playlist for this Monitor. The Pane 
Properties dialog appears. 

2 On the display you want to configure a playlist for, select Playlist for this Monitor. The 
Pane Properties dialog appears. 

3 Select Cycle through multiple Web pages. 
4 Click the Add button to add Web pages to the list. The Add URL to Playlist dialog 

appears. 
5 Enter the appropriate information in the following fields: 

 Title bar text. Enter the title bar name for the Dashboard display. 

 URL. Enter or paste the URL for the Web page you want to display in the following 
format: 

http://www.websitename.com/webpagename 

 Refresh interval (in seconds). Enter an amount of time (in seconds) for how long you 
would like the Web page to be on the screen. 

 WhatsUp Gold Web login. Either select a user from the drop-down list, or click the 
browse (...) button to choose a user from the WhatsUp Gold Web Login Library. This 
user account is used for the Dashboard application to log-in to a WhatsUp Gold Web 
page. Without a proper user account, the application is not able to display a 
password-protected Web page. If you are using a non-WhatsUp Gold Web page, set 
the Web login to None. 
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 Note: Other applications requiring a username and password to display Web pages can be 
used in the Dashboard Screen Manager. You can specify these other application username 
and passwords in the URL field, appended to the Web page URL. 

6 Click OK to add the new Web page to the playlist. 
7 Edit and Remove Web pages by selecting a Web page from the list and then clicking the 

Edit or Remove button. 
8 Click OK to save changes. 
 

About the licensing technology 

WhatsUp Gold v12 includes a new serial number based licensing technology for product 
activation.  

The serial number allows users to activate product evaluations for a limited time period or 
purchase a complete license. To access additional features for a product, users purchase an 
upgrade and then reactivate their product using the same serial number to turn on the new 
features. Users can also deactivate the product on one computer and reactivate it on another 
computer.   

Ipswitch continues to support previous Ipswitch products released with older licensing 
technologies until they reach end-of-life. The new licensing and product activation 
mechanism is not backwards compatible with previous versions of WhatsUp Gold. 

More licensing and support information is available for customers on the myipswitch.com 
web portal. The Web site provides users enhanced web-based capabilities to view and 
manage their Ipswitch licenses. 
 

Activating WhatsUp Gold for new or upgraded licenses 
If WhatsUp Gold is installed using the installation application downloaded from the Web link 
provided in the purchase confirmation email, the program is fully functional immediately 
after installation.  

If the WhatsUp Gold v12 license is not automatically activated during the installation or if you 
are upgrading from a previous WhatsUp Gold version, you can manually activate WhatsUp 
Gold using the activation program in the WhatsUp Gold group of the Windows Start menu. 

 Important: Make sure that you activate WhatsUp Gold before starting the application. The 
WhatsUp Gold polling engine will be turned off and a message tells you that the license has 
expired. The application is not functional until after it has been activated. 
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To activate WhatsUp Gold manually: 

 Note: Before you start the manual activation process, make sure that you have your product 
serial number available to use in the activation program. 

1 Click Start > Programs > Ipswitch WhatsUp Gold > Manage WhatsUp Gold License. 
The activation program appears. 
- or - 
If you run the WhatsUp Gold console at the end of the installation, it displays an Invalid 
License dialog. Click the Purchase/Unlock to start the license activation process. 

2 Follow the onscreen instructions to complete the product activation. 

 Note: When the activation is complete, a confirmation page indicates the license has been 
activated. If the activation does not complete successfully, you may be behind a proxy or 
firewall that is blocking the activation request. In this case, click the Offline button, then 
follow the onscreen instructions. 

For more help and information about licensing, go to the Ipswitch licensing portal 
(http://www.myipswitch.com/)
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